problem when activate the pugin

Home Forums Plugin Problems problem when activate the pugin

This topic contains 8 replies, has 2 voices, and was last updated by  jbesve 2 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1337

    jbesve
    Participant

    Hi I try to activate the plugin but I have the following error message:

    “Fatal error: Class ‘WP_REST_Controller’ not found in /home/wordpress/network/wp-content/plugins/sports-bench/functions/rest-api/sports-bench-bracket-rest-controller.php on line 16”

    Thanks for your answer

    #1338

    Jacob Martella
    Keymaster

    Hi,
    What version of WordPress do you have? If it’s below version 4.7, it’s not going to work.

    #1339

    jbesve
    Participant

    Yes it is below. I cannot update it so easily because there other site and constraint. So could you make a refund ? Thanks a lot.

    #1341

    jbesve
    Participant

    Hello,

    any answer ? if not, I will set a negative advice for the support.

    thank you in advance.

    #1342

    Jacob Martella
    Keymaster

    Hello,
    Sorry about that. I went out of town last week and it got buried on a to do list. It’s late where I am (central US), but I’ll send you that file when I get up in the morning.

    #1343

    Jacob Martella
    Keymaster

    Hello,
    I’ve changed the main file to not run the WP REST API stuff. You can download it at the link below. You’ll need to upload it via FTP, SFTP or your web host’s file manager to the wp-content/plugins/sports-bench directory. Let me know if that works for you.

    https://drive.google.com/open?id=1YSR_ZYuXSNJ7y60dEqyJrwnDWPiFBGj3

    #1344

    jbesve
    Participant

    Hello,

    Thank you.

    could you give me the access(permission) to googledrive to be able to download the file? Google ask me.

    Thanks a lot.

    #1345

    Jacob Martella
    Keymaster

    Sorry about that. I get confused with Google drive settings sometimes. Thought I turned on link sharing. It should be good to go now.

    Since you said your site is below WordPress 4.7, I feel like this is a good time to give you a bit of a heads up on what could be coming down the road (albeit a long way down the road if it ever happens):
    https://make.wordpress.org/core/2019/08/07/proposal-auto-update-old-versions-to-4-7/

    #1347

    jbesve
    Participant

    Thank you for the update. It works now. Thank you a lot !

    Joel

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.